Difference between revisions of "Emacs Starter Kit"

From WikEmacs
Jump to: navigation, search
(added basic ESK page)
 
m (Reverted edits by 91.200.13.70 (talk) to last revision by Pogin)
(2 intermediate revisions by 2 users not shown)
Line 9: Line 9:
  
 
= Basic setup =
 
= Basic setup =
 +
 +
You'll need Emacs 24, which comes with package.el. It's not hard to compile from source, but precompiled versions are readily available for Debian-based systems, Mac OS X, and Windows.
 +
 +
If you need to maintain compatibility with Emacs 23 or 22, you need to use version 1.
 +
 +
Add Marmalade as a package archive source in ~/.emacs.d/init.el:
 +
 +
{{Snippet|
 +
(require 'package)
 +
(add-to-list 'package-archives
 +
            '("marmalade" . "http://marmalade-repo.org/packages/") t)
 +
(package-initialize)
 +
}}
 +
 +
Evaluate that code by hitting {{Command|eval-buffer}} in {{Filename|init.el}}, then you can install it:
 +
 +
{{Command|package-refresh-contents}}
 +
 +
{{Command|package-install RET starter-kit RET}}
  
 
= Helpful keybindings =
 
= Helpful keybindings =
Line 15: Line 34:
  
 
= See Also =
 
= See Also =
 +
 +
[[Prelude]]
  
 
= Project Pages =
 
= Project Pages =

Revision as of 17:14, 27 December 2013

Emacs Starter Kit
Description Starter Kit
Author name of author
Maintainer Phil Hagelberg
Source https://github.com/technomancy/emacs-starter-kit

The Starter Kit provides a more pleasant set of defaults than you get normally with Emacs. It was originally intended for beginners, but it offers a nicely augmented working environment for anyone using Emacs.

Basic setup

You'll need Emacs 24, which comes with package.el. It's not hard to compile from source, but precompiled versions are readily available for Debian-based systems, Mac OS X, and Windows.

If you need to maintain compatibility with Emacs 23 or 22, you need to use version 1.

Add Marmalade as a package archive source in ~/.emacs.d/init.el:

(require 'package)
(add-to-list 'package-archives
             '("marmalade" . "http://marmalade-repo.org/packages/") t)
(package-initialize)

Evaluate that code by hitting M-x eval-buffer in init.el, then you can install it:

M-x package-refresh-contents

M-x package-install RET starter-kit RET

Helpful keybindings

Common Customization

See Also

Prelude

Project Pages

Tutorial Pages